[PVFS-users] compiling libpvfs.so.1.4

Phil Carns pcarns@hubcap.clemson.edu
Wed, 2 Aug 2000 14:04:13 -0400 (EDT)


> > What glibc and kernel versions are you running on your system?
> glibc 2.1.3 and 2.2.16

It may be best for you to just use the pvfs-kernel interface for linux
file system compatability for now.  We don't really support glibc 2.1.3
with the LD_PRELOAD wrappers yet and I'm starting to get more bug reports
from people trying to use the 2.1.2 wrappers in this situation.  I think
some of these problems would need to be addressed with a release that
specifically supports 2.1.3.

The kernel module causes a performance penalty in some cases, but it
provides better compatibility and will be easier to run on your
system.  The native pvfs interface library and Romio (MPI-IO) interface
also work correctly under glibc 2.1.3 without any problems.

-Phil