[PVFS2-users] 1.3.0 build problem with --enable-fast

Robert Latham robl at mcs.anl.gov
Thu Oct 13 16:52:14 EDT 2005


On Wed, Oct 12, 2005 at 02:54:27PM -0500, Ryuta Suzuki wrote:
> I try to build 1.3.0 with one of the option --enable-fast (which I used 
> to use for the older versions) but it doesn't seem to work on this new 
> version:

Hi Ryuta

Thanks for catching our error.  The following patch to pvfs2-server.h
makes things build with --enable-fast:

Index: src/server/pvfs2-server.h
===================================================================
RCS file: /projects/cvsroot/pvfs2-1/src/server/pvfs2-server.h,v
retrieving revision 1.121
diff -u -w -p -r1.121 pvfs2-server.h
--- src/server/pvfs2-server.h   23 Aug 2005 18:44:20 -0000      1.121
+++ src/server/pvfs2-server.h   13 Oct 2005 20:48:32 -0000
@@ -369,6 +369,9 @@ typedef struct PINT_server_op
  *
  * no return value
  */
+#ifdef GOSSIP_DISABLE_DEBUG
+#define PINT_ACCESS_DEBUG(__s_op, __mask, format, f...) do {} while (0)
+#else
 #define PINT_ACCESS_DEBUG(__s_op, __mask, format, f...)                     \
 do {                                                                        \
     PVFS_handle __handle;                                                   \
@@ -398,6 +401,7 @@ do {                                    
         __gossip_debug(__mask, 'A', __pint_access_buffer, ##f);             \
     }                                                                       \
 } while(0);
+#endif
 
 /* server operation state machines */
 extern struct PINT_state_machine_s pvfs2_get_config_sm;

==rob

-- 
Rob Latham
Mathematics and Computer Science Division    A215 0178 EA2D B059 8CDF
Argonne National Labs, IL USA                B29D F333 664A 4280 315B


More information about the PVFS2-users mailing list